]> Creatis software - clitk.git/blobdiff - common/CMakeLists.txt
GateAsciiImageIO is now cross-platform using itksys::RegularExpression
[clitk.git] / common / CMakeLists.txt
index a4b26142178a03624a610e44498a6b4646148348..6026b72e304d4a21e9a3df3d966f90779b161d4a 100644 (file)
@@ -13,6 +13,8 @@ SET(clitkCommon_SRC
   clitkImageCommon.cxx
   clitkTransformUtilities.cxx
   clitkIO.cxx
+  clitkGateAsciiImageIO.cxx
+  clitkGateAsciiImageIOFactory.cxx
   clitkVoxImageIO.cxx  
   clitkVoxImageIOFactory.cxx
   clitkVfImageIO.cxx  
@@ -27,38 +29,33 @@ SET(clitkCommon_SRC
   clitkDicomRTDoseIO.cxx
   clitkDicomRTDoseIOFactory.cxx
   clitkOrientation.cxx
-  vvImage.cxx
   clitkImageToImageGenericFilterBase.cxx
   clitkExceptionObject.cxx
   clitkFilterBase.cxx
-)  
-
-### if LIBSTATGRAB is installed, add clitkMemoryUsage.cxx in the library
-IF(CLITK_MEMORY_INFO)
-  FIND_PROGRAM(LIBSTATGRAB NAMES statgrab PATHS)
-  IF (${LIBSTATGRAB} MATCHES "LIBSTATGRAB-NOTFOUND")
-    MESSAGE( FATAL_ERROR "libstatgrab NOT FOUND -> please install http://www.i-scream.org/libstatgrab/")
-  ELSE (${LIBSTATGRAB} MATCHES "LIBSTATGRAB-NOTFOUND")
-    SET(clitkCommon_SRC ${clitkCommon_SRC} clitkMemoryUsage.cxx)
-  ENDIF (${LIBSTATGRAB} MATCHES "LIBSTATGRAB-NOTFOUND")  
-ENDIF(CLITK_MEMORY_INFO)
+  clitkMemoryUsage.cxx
+  vvImage.cxx
+  vvImageReader.cxx
+  vvImageWriter.cxx
+)
 
 ### Declare clitkCommon library
 ADD_LIBRARY(clitkCommon STATIC ${clitkCommon_SRC})
 
-### Add libstatgrab if needed
-IF(CLITK_MEMORY_INFO)
-    TARGET_LINK_LIBRARIES(clitkCommon statgrab)
-ENDIF(CLITK_MEMORY_INFO)
+IF(NOT ${LIBSTATGRAB} MATCHES "LIBSTATGRAB-NOTFOUND")
+  TARGET_LINK_LIBRARIES(clitkCommon statgrab)
+ENDIF(NOT ${LIBSTATGRAB} MATCHES "LIBSTATGRAB-NOTFOUND")
 
-TARGET_LINK_LIBRARIES(clitkCommon vtkCommon vtkImaging vtkHybrid ITKBasicFilters)
+TARGET_LINK_LIBRARIES(clitkCommon vtkCommon vtkImaging ${ITK_LIBRARIES})
 
 ADD_LIBRARY(clitkDicomRTStruct STATIC
   clitkDicomRT_Contour.cxx
   clitkDicomRT_ROI.cxx
   clitkDicomRT_StructureSet.cxx
-  clitkDicomRT_ROI_ConvertToImageFilter.cxx
+  clitkDicomRTStruct2ImageFilter.cxx
 )
 
+TARGET_LINK_LIBRARIES(clitkDicomRTStruct vtkHybrid) 
+
 #ADD_LIBRARY(clitkCommonShared SHARED ${clitkCommon_SRC})
 #SET_TARGET_PROPERTIES(clitkCommonShared PROPERTIES COMPILE_FLAGS -fPIC)
+