]> Creatis software - FrontAlgorithms.git/blobdiff - tests/image/Dijkstra/CMakeLists.txt
...
[FrontAlgorithms.git] / tests / image / Dijkstra / CMakeLists.txt
diff --git a/tests/image/Dijkstra/CMakeLists.txt b/tests/image/Dijkstra/CMakeLists.txt
new file mode 100644 (file)
index 0000000..a68b3cc
--- /dev/null
@@ -0,0 +1,22 @@
+## =========================================================================
+## @author Leonardo Florez Valencia
+## @email florez-l@javeriana.edu.co
+## =========================================================================
+
+set(_pfx test_fpa_Image_Dijkstra_)
+set(
+  _tests
+  Identity
+  Invert
+  Gaussian
+  ExtractAxis
+  Skeleton
+  )
+include_directories(${PROJECT_SOURCE_DIR}/lib ${PROJECT_BINARY_DIR}/lib)
+
+foreach(_t ${_tests})
+  add_executable(${_pfx}${_t} ${_t}.cxx)
+  target_link_libraries(${_pfx}${_t} fpa)
+endforeach(_t)
+
+## eof - $RCSfile$