]> Creatis software - FrontAlgorithms.git/blobdiff - tests/image/VTK/CMakeLists.txt
...
[FrontAlgorithms.git] / tests / image / VTK / CMakeLists.txt
diff --git a/tests/image/VTK/CMakeLists.txt b/tests/image/VTK/CMakeLists.txt
new file mode 100644 (file)
index 0000000..3328b46
--- /dev/null
@@ -0,0 +1,21 @@
+## =========================================================================
+## @author Leonardo Florez Valencia
+## @email florez-l@javeriana.edu.co
+## =========================================================================
+
+if(VTK_FOUND)
+  set(_pfx test_fpa_Image_VTK_)
+  set(
+    _tests
+    PolyLineParametricPathToPolyData
+    SkeletonToPolyData
+    )
+  include_directories(${PROJECT_SOURCE_DIR}/lib ${PROJECT_BINARY_DIR}/lib)
+
+  foreach(_t ${_tests})
+    add_executable(${_pfx}${_t} ${_t}.cxx)
+    target_link_libraries(${_pfx}${_t} fpa ${VTK_LIBRARIES})
+  endforeach(_t)
+endif(VTK_FOUND)
+
+## eof - $RCSfile$