]> Creatis software - bbtk.git/blobdiff - kernel/appli/bbi/CMakeLists.txt
#249 8BBTK Feature New Normal - wt-version kernel
[bbtk.git] / kernel / appli / bbi / CMakeLists.txt
index 11857f8d3876c21e23ec9ca3b3bc47c7c729b5a4..a8a2ddbce007f178a9b779c6eea37661544bf168 100644 (file)
@@ -1,3 +1,27 @@
+ # ---------------------------------------------------------------------
+ #
+ # Copyright (c) CREATIS (Centre de Recherche en Acquisition et Traitement de l'Image
+ #                        pour la SantÈ)
+ # Authors : Eduardo Davila, Frederic Cervenansky, Claire Mouton
+ # Previous Authors : Laurent Guigues, Jean-Pierre Roux
+ # CreaTools website : www.creatis.insa-lyon.fr/site/fr/creatools_accueil
+ #
+ #  This software is governed by the CeCILL-B license under French law and
+ #  abiding by the rules of distribution of free software. You can  use,
+ #  modify and/ or redistribute the software under the terms of the CeCILL-B
+ #  license as circulated by CEA, CNRS and INRIA at the following URL
+ #  http://www.cecill.info/licences/Licence_CeCILL-B_V1-en.html
+ #  or in the file LICENSE.txt.
+ #
+ #  As a counterpart to the access to the source code and  rights to copy,
+ #  modify and redistribute granted by the license, users are provided only
+ #  with a limited warranty  and the software's author,  the holder of the
+ #  economic rights,  and the successive licensors  have only  limited
+ #  liability.
+ #
+ #  The fact that you are presently reading this means that you have had
+ #  knowledge of the CeCILL-B license and that you accept its terms.
+ # ------------------------------------------------------------------------ */
 
 #OPTION(BUILD_bbi_GRAPHICAL "Build bbi in graphical mode (requires wxWidgets)" OFF)
 #SWITCH_ON_IF_ALL_BUILD(BUILD_bbi_GRAPHICAL)
@@ -11,13 +35,25 @@ SET(SOURCES
   )
 
 
-IF(bbtk_USE_WXWIDGETS AND WIN32)
+IF(BBTK_USE_WXWIDGETS AND WIN32)
   ADD_EXECUTABLE(bbi WIN32 ${SOURCES})  
   SET_TARGET_PROPERTIES(bbi PROPERTIES LINK_FLAGS /subsystem:console )
-ELSE(bbtk_USE_WXWIDGETS AND WIN32)
-  ADD_EXECUTABLE(bbi ${SOURCES})  
-ENDIF(bbtk_USE_WXWIDGETS AND WIN32)
+ELSE(BBTK_USE_WXWIDGETS AND WIN32)
+  ADD_EXECUTABLE(bbi MACOSX_BUNDLE ${SOURCES})  
+ENDIF(BBTK_USE_WXWIDGETS AND WIN32)
 
 
 TARGET_LINK_LIBRARIES(bbi bbtk)
 INSTALL_TARGETS(/bin/ bbi)
+
+
+IF(USE_WT)
+       SET(SOURCES bbiWeb )
+       ADD_EXECUTABLE(bbiWeb.wt MACOSX_BUNDLE ${SOURCES})  
+       TARGET_LINK_LIBRARIES(bbiWeb.wt bbtk)
+       INSTALL_TARGETS(/bin/ bbiWeb.wt)
+ENDIF(USE_WT)
+
+
+
+