]> Creatis software - cpPlugins.git/blobdiff - appli/bash/CMakeLists.txt
Moved to version 1.0
[cpPlugins.git] / appli / bash / CMakeLists.txt
diff --git a/appli/bash/CMakeLists.txt b/appli/bash/CMakeLists.txt
new file mode 100644 (file)
index 0000000..e375e7a
--- /dev/null
@@ -0,0 +1,34 @@
+## =========================================================================
+## @author Leonardo Florez-Valencia (florez-l@javeriana.edu.co)
+## =========================================================================
+
+cpPlugins_BuildExecutable(
+  cpPlugins_MOC
+  INSTALL
+  SOURCES MOC.cxx
+  INCLUDES ${PROJECT_SOURCE_DIR}/lib ${PROJECT_BINARY_DIR}/lib
+  LINKS ${Boost_LIBRARIES} cpPlugins_mstch
+  )
+
+cpPlugins_BuildExecutable(
+  cpPlugins_HostCreator
+  INSTALL
+  SOURCES HostCreator.cxx
+  LINKS ${Boost_LIBRARIES}
+  )
+
+cpPlugins_BuildExecutable(
+  cpPlugins_InteractivePipelineCreator
+  INSTALL
+  SOURCES InteractivePipelineCreator.cxx.d
+  LINKS cpPlugins_TinyCon cpPlugins
+  )
+
+cpPlugins_BuildExecutable(
+  cpPlugins_ExecutePipeline
+  INSTALL
+  SOURCES ExecutePipeline.cxx
+  LINKS cpPlugins
+  )
+
+## eof - $RCSfile$