]> Creatis software - cpPlugins.git/blobdiff - appli/examples/CMakeLists.txt
Moved to version 1.0
[cpPlugins.git] / appli / examples / CMakeLists.txt
diff --git a/appli/examples/CMakeLists.txt b/appli/examples/CMakeLists.txt
new file mode 100644 (file)
index 0000000..5e71ab7
--- /dev/null
@@ -0,0 +1,29 @@
+## =========================================================================
+## @author Leonardo Florez-Valencia (florez-l@javeriana.edu.co)
+## =========================================================================
+
+option(cpPlugins_BUILD_EXAMPLES "Build examples?" OFF)
+if(cpPlugins_BUILD_EXAMPLES)
+  set(
+    _examples
+    Parameters
+    ReadRawFile_00
+    ReadRawFile_01
+    ReadRawFile_02
+    ReadWriteRawFile_00
+    ReadWriteRawFile_01
+    ReadWriteRawFile_02
+    ComplexAppend
+    )
+  foreach(_e ${_examples})
+    cpPlugins_BuildExecutable(
+      example_${_e}
+      SOURCES ${_e}.cxx
+      INCLUDES ${PROJECT_SOURCE_DIR}/lib ${PROJECT_BINARY_DIR}/lib
+      LINKS cpPlugins cpPluginsBase
+      )
+
+  endforeach(_e)
+endif(cpPlugins_BUILD_EXAMPLES)
+
+## eof - $RCSfile$