]> Creatis software - cpPlugins.git/blobdiff - cmake/CMakeLists.txt
Moved to version 1.0
[cpPlugins.git] / cmake / CMakeLists.txt
index e942ae913475019ad5877a0ee2a0f3112f9cdde3..e3d07e5c20218e671a0bdea024c3062070465d86 100644 (file)
@@ -1,11 +1,19 @@
-## =====================
-## == Configure files ==
-## =====================
+## =========================================================================
+## @author Leonardo Florez-Valencia (florez-l@javeriana.edu.co)
+## =========================================================================
 
-CONFIGURE_FILE(
-  cpPluginsConfig.cmake.in
-  ${PROJECT_BINARY_DIR}/cpPluginsConfig.cmake
-  @ONLY
+set(
+  _scripts
+  cpPlgDefinitions.cmake
+  cpPlgFunctions.cmake
+  cpPlg3rdParty.cmake
+  cpPlgInstallCommands.cmake
   )
+foreach(_s ${_scripts})
+  install(
+    FILES "${_s}"
+    DESTINATION "lib/cmake/${PROJECT_NAME}"
+    )
+endforeach(_s)
 
 ## eof - $RCSfile$