]> Creatis software - cpPlugins.git/blobdiff - lib/CMakeLists.txt
...
[cpPlugins.git] / lib / CMakeLists.txt
index f10db6baea6d6623727d25687114a252a71bebfc..0183e8ea86b203c74114d1efe08976e195e95230 100644 (file)
@@ -45,6 +45,29 @@ TARGET_LINK_LIBRARIES(
 CompileLibFromDir(cpBaseQtApplication SHARED cpBaseQtApplication)
 TARGET_LINK_LIBRARIES(cpBaseQtApplication cpPlugins)
 
+## ====================
+## == Base libraries ==
+## ====================
+
+IF(USE_QT4)
+  SET(
+    cpPlugins_BaseLibraries
+    cp_tinyxml2
+    cp_QCustomPlot
+    cpExtensions
+    cpPlugins
+    CACHE INTERNAL "All locally compiled libraries." FORCE
+    )
+ELSE(USE_QT4)
+  SET(
+    cpPlugins_BaseLibraries
+    cp_tinyxml2
+    cpExtensions
+    cpPlugins
+    CACHE INTERNAL "All locally compiled libraries." FORCE
+    )
+ENDIF(USE_QT4)
+
 ## ===================================
 ## == Libraries to dynamically load ==
 ## ===================================