]> Creatis software - cpPlugins.git/blobdiff - lib/CMakeLists.txt
...
[cpPlugins.git] / lib / CMakeLists.txt
index e149793dd3ee113f6f813e0a4ad3bfddacb58443..4d6f6008aaa6118172437146268925cf4f505349 100644 (file)
@@ -8,7 +8,9 @@ IF(USE_QT4)
   TARGET_LINK_LIBRARIES(cp_QCustomPlot ${QT_LIBRARIES})
 ENDIF(USE_QT4)
 CompileLibFromDir(cpExtensions SHARED cpExtensions)
-TARGET_LINK_LIBRARIES(cpExtensions ${QT_LIBRARIES} ${ITK_LIBRARIES} ${VTK_LIBRARIES})
+TARGET_LINK_LIBRARIES(
+  cpExtensions ${QT_LIBRARIES} ${ITK_LIBRARIES} ${VTK_LIBRARIES}
+  )
 
 ## ===============
 ## == Instances ==
@@ -36,6 +38,13 @@ TARGET_LINK_LIBRARIES(
   ${cpPlugins_Instances}
   )
 
+## =========================
+## == Even more libraries ==
+## =========================
+
+CompileLibFromDir(cpBaseQtApplication SHARED cpBaseQtApplication)
+TARGET_LINK_LIBRARIES(cpBaseQtApplication cpPlugins)
+
 ## ===================================
 ## == Libraries to dynamically load ==
 ## ===================================