]> Creatis software - creaBruker.git/blobdiff - appli/template_appli/CMakeLists.txt
Unify with new CreaNewProject
[creaBruker.git] / appli / template_appli / CMakeLists.txt
index 020be7eb9eacbb0311a337b0d5c05decc8fdca12..30619a8bd14e0f85cbd668d4ce08443cf69b77c9 100644 (file)
@@ -1,18 +1,34 @@
 #----------------------------------------------------------------------------
 # SET THE NAME OF YOUR EXECUTABLE
+# Replace 'MyExe' by the name you want to give your executable.
+# (a good policy is to give the executable the same name that the directory)
+
+#########################
 SET ( EXE_NAME   MyExe  )
+#########################
+
 #----------------------------------------------------------------------------
 
 #----------------------------------------------------------------------------
 # EXECUTABLE SOURCES (TO BE COMPILED)
 # EITHER LIST ALL .cxx, *.cpp, *.cc IN CURRENT DIR USING NEXT LINE:
+
 FILE(GLOB ${EXE_NAME}_SOURCES *.cxx *.cpp *.cc)
+
 # OR MANUALLY LIST YOUR FILES WITH NEXT COMMAND (WITHOUT EXTENSION)
 #  SET ( ${EXE_NAME}_SOURCES 
 #   
 #    )
 #----------------------------------------------------------------------------
 
+INCLUDE_DIRECTORIES (
+
+# Add here the directories holding th extra .h files you need
+# e.g.
+# ../../lib/<my_library_I_just_created>
+
+)
+
 #----------------------------------------------------------------------------
 # DEPENDENCIES (LIBRARIES TO LINK WITH)
 SET ( ${EXE_NAME}_LINK_LIBRARIES
@@ -23,6 +39,11 @@ SET ( ${EXE_NAME}_LINK_LIBRARIES
   #    ${ITK_LIBRARIES}
   #    ${GDCM_LIBRARIES}
   #    ${BOOST_LIBRARIES}
+
+  # Add here those agmonst the various (?) PROJECT LIBRARIES
+  # you need for the current executable
+  # (If you created only one Library, don't forget it !...) 
+
   )
 #----------------------------------------------------------------------------