]> Creatis software - creaBruker.git/blobdiff - doc/CMakeLists.txt
Added CMake configuration to enable CDash tests.
[creaBruker.git] / doc / CMakeLists.txt
index 2f9447ea5898557344e63cf5fcd95c48f1fc44dc..e22e19a6d9ce0ea602df6af599e871e4e0f3a8fb 100644 (file)
@@ -1,9 +1,33 @@
+# ---------------------------------------------------------------------
+#
+# Copyright (c) CREATIS (Centre de Recherche en Acquisition et Traitement de l'Image 
+#                        pour la Santé)
+# Authors : Eduardo Davila, Frederic Cervenansky, Claire Mouton
+# Previous Authors : Laurent Guigues, Jean-Pierre Roux
+# CreaTools website : www.creatis.insa-lyon.fr/site/fr/creatools_accueil
+#
+#  This software is governed by the CeCILL-B license under French law and 
+#  abiding by the rules of distribution of free software. You can  use, 
+#  modify and/ or redistribute the software under the terms of the CeCILL-B 
+#  license as circulated by CEA, CNRS and INRIA at the following URL 
+#  http://www.cecill.info/licences/Licence_CeCILL-B_V1-en.html 
+#  or in the file LICENSE.txt.
+#
+#  As a counterpart to the access to the source code and  rights to copy,
+#  modify and redistribute granted by the license, users are provided only
+#  with a limited warranty  and the software's author,  the holder of the
+#  economic rights,  and the successive licensors  have only  limited
+#  liability. 
+#
+#  The fact that you are presently reading this means that you have had
+#  knowledge of the CeCILL-B license and that you accept its terms.
+# ------------------------------------------------------------------------
 
 
 #-----------------------------------------------------------------------------
 IF(BUILD_${PROJECT_NAME}_DOC AND BUILD_${PROJECT_NAME}_DOC_DOXYGEN)
   INCLUDE(../cmake/UserBuildDoxygenDoc.cmake)
-  SUBDIRS(UserDoxygen)
+  ADD_SUBDIRECTORY(UserDoxygen)
 ENDIF(BUILD_${PROJECT_NAME}_DOC AND BUILD_${PROJECT_NAME}_DOC_DOXYGEN)
 #-----------------------------------------------------------------------------
 
@@ -29,7 +53,7 @@ ENDIF(BUILD_${PROJECT_NAME}_DOC AND BUILD_${PROJECT_NAME}_DOC_GUIDES_HTML)
 
 #-----------------------------------------------------------------------------
 IF(BUILD_${PROJECT_NAME}_DOC AND BUILD_${PROJECT_NAME}_DOC_GUIDES_PDF OR BUILD_${PROJECT_NAME}_DOC_GUIDES_HTML)  
-  SUBDIRS(UserDocumentation)  
+  ADD_SUBDIRECTORY(UserDocumentation)  
 ENDIF(BUILD_${PROJECT_NAME}_DOC AND BUILD_${PROJECT_NAME}_DOC_GUIDES_PDF OR BUILD_${PROJECT_NAME}_DOC_GUIDES_HTML)
 #-----------------------------------------------------------------------------
 # Web site 
@@ -69,7 +93,7 @@ IF(BUILD_${PROJECT_NAME}_DOC)
     ) 
 
   # Recurse it bbtkWebSite dir
-  SUBDIRS(template_WebSite)
+  ADD_SUBDIRECTORY(template_WebSite)