]> Creatis software - creaCLI.git/blobdiff - ModuleCall/CMakeLists.txt
Simple DL-Open example
[creaCLI.git] / ModuleCall / CMakeLists.txt
diff --git a/ModuleCall/CMakeLists.txt b/ModuleCall/CMakeLists.txt
new file mode 100644 (file)
index 0000000..474b985
--- /dev/null
@@ -0,0 +1,32 @@
+CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
+project (Inter)
+set (Inter_VERSION_MAJOR 1)
+set (Inter_VERSION_MINOR 0)
+
+SET(CMAKE_CXX_FLAGS "-ldl -w")
+
+FIND_PACKAGE (GenerateCLP REQUIRED)
+if (GenerateCLP_FOUND)
+  INCLUDE(${GenerateCLP_USE_FILE})
+endif (GenerateCLP_FOUND)
+
+FIND_PACKAGE (ModuleDescriptionParser REQUIRED)
+if (ModuleDescriptionParser_FOUND)
+  INCLUDE(${ModuleDescriptionParser_USE_FILE})
+endif (ModuleDescriptionParser_FOUND)
+
+SET(INCLUDE_DIRS
+  ${GenerateCLP_BINARY_DIR}
+  ${GenerateCLP_SOURCE_DIR}
+  ${ModuleDescriptionParser_BINARY_DIR}
+  ${ModuleDescriptionParser_SOURCE_DIR}
+  )
+
+SET(LINK_DIRECTORIES
+  ${GenerateCLP_LINK_DIRECTORY}
+  ${ModuleDescriptionParser_LINK_DIRECTORY}
+  )
+       
+ADD_EXECUTABLE (interoperating_Baby main.cpp CreationTool.cxx)
+TARGET_LINK_LIBRARIES (interoperating_Baby ${ModuleDescriptionParser_LIBRARY} ModuleDescriptionParser )
+