]> Creatis software - creaContours.git/blobdiff - bbtk/CMakeLists.txt
*** empty log message ***
[creaContours.git] / bbtk / CMakeLists.txt
index a8408caa8141de8be416c6fa04b35b6312f26a15..1e5e155a497f341cd6cf45b8ce14fe0951592d23 100644 (file)
@@ -126,13 +126,20 @@ SET(${BBTK_PACKAGE_NAME}_INCLUDE_DIRS
 #===========================================================================
 
 #===========================================================================
+
+IF (${BUILD_ParserOsirix})
+  SET ( PARSEROSIRIX_LIBRARIES "kernelParserOsirix")
+ELSE(${BUILD_ParserOsirix})
+  SET ( PARSEROSIRIX_LIBRARIES "")
+ENDIF (${BUILD_ParserOsirix})
+
 SET(${BBTK_PACKAGE_NAME}_LIBS 
   # LIST HERE THE ADDITIONAL LIBS TO LINK AGAINST
   # EXCEPT : the same libs than for INCLUDE_DIRS 
        Interface_ManagerContour_NDimensions_lib
        Interface_Icons_NDimensions_lib
        kernel_ManagerContour_NDimensions_lib
-       kernelParserOsirix
+       ${PARSEROSIRIX_LIBRARIES} 
        ${creaEnvironment_LIBRARIES} 
        ${creaMaracasVisu_LIBRARIES}