]> Creatis software - creaImageIO.git/blobdiff - appli/CMakeLists.txt
Feature #1764
[creaImageIO.git] / appli / CMakeLists.txt
index 0da3863b8f5377cc9b851d16935755228a67da1e..e20c064af563fe66b3f6ab5dc2ee600af5b55941 100644 (file)
@@ -1,3 +1,28 @@
+# ---------------------------------------------------------------------
+#
+# Copyright (c) CREATIS (Centre de Recherche en Acquisition et Traitement de l'Image 
+#                        pour la Santé)
+# Authors : Eduardo Davila, Frederic Cervenansky, Claire Mouton
+# Previous Authors : Laurent Guigues, Jean-Pierre Roux
+# CreaTools website : www.creatis.insa-lyon.fr/site/fr/creatools_accueil
+#
+#  This software is governed by the CeCILL-B license under French law and 
+#  abiding by the rules of distribution of free software. You can  use, 
+#  modify and/ or redistribute the software under the terms of the CeCILL-B 
+#  license as circulated by CEA, CNRS and INRIA at the following URL 
+#  http://www.cecill.info/licences/Licence_CeCILL-B_V1-en.html 
+#  or in the file LICENSE.txt.
+#
+#  As a counterpart to the access to the source code and  rights to copy,
+#  modify and redistribute granted by the license, users are provided only
+#  with a limited warranty  and the software's author,  the holder of the
+#  economic rights,  and the successive licensors  have only  limited
+#  liability. 
+#
+#  The fact that you are presently reading this means that you have had
+#  knowledge of the CeCILL-B license and that you accept its terms.
+# ------------------------------------------------------------------------
+
 IF(!USE_INSTALL_APP)
   ADD_SUBDIRECTORY(gimmick)
    ADD_SUBDIRECTORY(TestGimmickReaderDialog)
@@ -16,13 +41,15 @@ IF(!USE_INSTALL_APP)
   ENDIF(USE_QT4)
   
 IF(USE_ITK)
-#EED ADD_SUBDIRECTORY(TestWxItkView)
+ ADD_SUBDIRECTORY(TestWxItkView)
 ENDIF(USE_ITK)
   #ADD_SUBDIRECTORY(TestWxGimmickReaderDialogJava)
 #LSE (BUILD_V2)
  # ADD_SUBDIRECTORY(TestWxGimmickDialog)
 #ENDIF (BUILD_V2)
-
+IF(USE_QT4)
+ ADD_SUBDIRECTORY(creaImageIOQtApp)
+ENDIF(USE_QT4)