]> Creatis software - creaImageIO.git/blobdiff - win64/sqlite/CMakeLists.txt
Merge branch 'master' into changestoITK3and4
[creaImageIO.git] / win64 / sqlite / CMakeLists.txt
diff --git a/win64/sqlite/CMakeLists.txt b/win64/sqlite/CMakeLists.txt
deleted file mode 100644 (file)
index 558a32e..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-cmake_minimum_required ( VERSION 2.6 FATAL_ERROR )
-
-project ( sqlite3 C )
-
-SET( CMAKE_INSTALL_PREFIX "" )
-
-set ( SOURCES sqlite3.c )
-set ( HEADERS sqlite3.h )
-
-if ( WIN32 )
-  if ( MSVC )
-#    set ( CMAKE_SHARED_LINKER_FLAGS /DEF:sqlite3.def )
-#    set ( SQLITE3_DEF_FILE "${CMAKE_CURRENT_BINARY_DIR}/sqlite3.def" )
-     add_definitions( "-DSQLITE_API=__declspec(dllexport)" )
-  endif ( MSVC )
-endif ( WIN32 )
-
-   FIND_PACKAGE(GDCM REQUIRED)
-   INCLUDE_DIRECTORIES(${GDCM_INCLUDE_DIRS})
-  
-
-#  ${GDCM_DIR}/bin/Debug/gdcmDSED.lib
- # ${GDCM_DIR}/bin/Debug/gdcmMSFF.lib)
-  
-add_library ( sqlite3 SHARED
-  ${SOURCES}
-  ${HEADERS}
-  gdcmDSED.lib
-)
-
-INSTALL ( TARGETS sqlite3
-  RUNTIME DESTINATION bin
-  LIBRARY DESTINATION lib
-  ARCHIVE DESTINATION lib
-)
-
-INSTALL ( FILES sqlite3.h DESTINATION include )