]> Creatis software - creaRigidRegistration.git/blobdiff - lib/CMakeLists.txt
Tried changing to dynamic library, left as static
[creaRigidRegistration.git] / lib / CMakeLists.txt
index 03bc324cf6fed08d4f72f357cec309d9dbe15e79..bdd1edbbe99e74255534df4b2b1ef2db9f8ee884 100644 (file)
@@ -37,7 +37,7 @@ IF ( BUILD_${LIBRARY_NAME} )
   # LIBRARY SOURCES (TO BE COMPILED)
   # EITHER LIST ALL .cxx, *.cpp, *.cc IN CURRENT DIR USING NEXT LINE:
   
-  FILE(GLOB ${LIBRARY_NAME}_SOURCES *.cxx *.cpp *.cc)
+  FILE(GLOB ${LIBRARY_NAME}_SOURCES *.cxx *.cpp *.cc *.h)
   
   # OR MANUALLY LIST YOUR FILES WITH NEXT COMMAND (WITHOUT EXTENSION)
   #  SET ( ${LIBRARY_NAME}_SOURCES 
@@ -72,12 +72,12 @@ IF ( BUILD_${LIBRARY_NAME} )
   # if you need to create a static library
   # comment out the following line :
   
-  CREA_ADD_LIBRARY( ${LIBRARY_NAME} )
+  #CREA_ADD_LIBRARY( ${LIBRARY_NAME} )
   
   # and uncomment the 2 lines hereafter:
   
-  ADD_LIBRARY(${LIBRARY_NAME} STATIC  ${${LIBRARY_NAME}_SOURCES})
-  TARGET_LINK_LIBRARIES(${LIBRARY_NAME} ${${LIBRARY_NAME}_LINK_LIBRARIES} )
+  ADD_LIBRARY(${LIBRARY_NAME} STATIC  ${${LIBRARY_NAME}_SOURCES})
+  TARGET_LINK_LIBRARIES(${LIBRARY_NAME} ${${LIBRARY_NAME}_LINK_LIBRARIES} )
   
   #
   #----------------------------------------------------------------------------