]> Creatis software - creaToolsTools.git/blobdiff - Install_ThirdParty/cmake/crea_ThirdParty_Libraries/CMakeLists.txt
Windows installers , Linux bbtk compilation
[creaToolsTools.git] / Install_ThirdParty / cmake / crea_ThirdParty_Libraries / CMakeLists.txt
index aec2f68f1053f3c214fc885a906db7ef71d787ed..a63deb2d095ecf8ec4377025fdf3b982c92959ed 100644 (file)
@@ -1,36 +1,13 @@
-# ---------------------------------------------------------------------
-#
-# Copyright (c) CREATIS (Centre de Recherche en Acquisition et Traitement de l'Image 
-#                        pour la Santé)
-# Authors : Eduardo Davila, Frederic Cervenansky, Claire Mouton
-#
-#  This software is governed by the CeCILL-B license under French law and 
-#  abiding by the rules of distribution of free software. You can  use, 
-#  modify and/ or redistribute the software under the terms of the CeCILL-B 
-#  license as circulated by CEA, CNRS and INRIA at the following URL 
-#  http://www.cecill.info/licences/Licence_CeCILL-B_V1-en.html 
-#  or in the file LICENSE.txt.
-#
-#  As a counterpart to the access to the source code and  rights to copy,
-#  modify and redistribute granted by the license, users are provided only
-#  with a limited warranty  and the software's author,  the holder of the
-#  economic rights,  and the successive licensors  have only  limited
-#  liability. 
-#
-#  The fact that you are presently reading this means that you have had
-#  knowledge of the CeCILL-B license and that you accept its terms.
-# ------------------------------------------------------------------------  
-
 CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
 
 ###################################
-PROJECT(crea_ThirdParty_Libraries)
+PROJECT(crea_TPL)
 ###################################
 
 #==================================
 # The project version
 SET(PROJECT_MAJOR_VERSION 3)
-SET(PROJECT_MINOR_VERSION 1)
+SET(PROJECT_MINOR_VERSION 2)
 SET(PROJECT_BUILD_VERSION 0)
 #==================================
 
@@ -80,6 +57,41 @@ MARK_AS_ADVANCED(
 #==================================
 
 
+
+
+MACRO (TODAY RESULT)
+    IF (WIN32)
+        EXECUTE_PROCESS(COMMAND "cmd" " /C date /T" OUTPUT_VARIABLE ${RESULT})
+        string(REGEX REPLACE "(..)/(..)/..(..).*" "\\1/\\2/\\3" ${RESULT} ${${RESULT}})
+    ELSEIF(UNIX)
+        EXECUTE_PROCESS(COMMAND "date" "+%d/%m/%Y" OUTPUT_VARIABLE ${RESULT})
+        string(REGEX REPLACE "(..)/(..)/..(..).*" "\\1/\\2/\\3" ${RESULT} ${${RESULT}})
+    ELSE (WIN32)
+        MESSAGE(SEND_ERROR "date not implemented")
+        SET(${RESULT} 000000)
+    ENDIF (WIN32)
+ENDMACRO (TODAY)
+
+
+TODAY(CREATOOLS_COMPILATION_DATE)
+
+
+##         Project: @CMAKE_PROJECT_NAME@
+##         Version: @PROJECT_MAJOR_VERSION@.@PROJECT_MINOR_VERSION@.@PROJECT_BUILD_VERSION@
+##        Platform: @CREATOOLS_PLATFORM@
+##      Build Type: @CREATOOLS_BUILDTYPE@
+##Compilation date: @CREATOOLS_COMPILATION_DATE@
+ CONFIGURE_FILE(
+    ${CMAKE_CURRENT_SOURCE_DIR}/Version.txt.in
+    ${${CMAKE_PROJECT_NAME}_BINARY_DIR}/Version.txt
+    @ONLY IMMEDIATE
+    )
+
+
+
+
+
+
 #==================================
 # Subdirs
 #SUBDIRS(appli)